Contoh Aplikasi Vb.net


Alhamdulillah ya,,, ternyata tantangan yang dikasih ma dosen selesai juga. Aq membuat aplikasi sederhana yang dibuat dengan Visual Studio 2005(vb.net) yaitu aplikasi untuk Pemilihan Umum.

Kalau teman2 mau, yuk silahkan sedot aja disini …

Download Here…

 

skenario simple:

Jalanin aja project nya, kebetulan saya menggunakan Visual Studio 2005. Ketika di Run, Form login akan muncul

Nobp diatas merupakan nobp sebagai Admin, yang mana dapat melihat hasil suara yang diperoleh. Apabila Nobp lain kita inputkan, maka akan muncul sebuah pesan, yang nantinya kita disuruh untuk mengaktifkan Nobp mahasiswa tersebut agar dapat memilih…

ketika diklik OK, akan muncul sebuah form baru yang mana untuk mengaktifkan nobp tersebut..

jika sudah diaktifkan, kita akan kembali ke Form login. Kemudian inputkan, maka kita akan menuju ke Form Pemilihan :

…….

sekian dulu skenario nya,,untuk memahami lebih lanjut silahkan ja download demonya…

mudah2an bermanfaat…!!!

 

Dynamic Routing


Dynamic Routing adalah Routing yang tidak berpengaruh jika terjadi perubahan IP pada Router yang lain (Dapat menyesuaikan keadaaan). Lebih kurang gitu lah pengertiannya…hehehehe ^_^

Pada kali ini, saya akan share dari mata kuliah Jaringan Komputer Lanjutan yang saya dapati. Y…. sekalian ngulang2 juga.

Kita langsung aja membuat sebuah kasuk membangun sebuah jaringan dengan metode Dynamic Routing menggunakan Packet Tracer.

Berikut tampilannya :

pada gambar diatas, saya mencoba menggunakan 3 buah router yang saya beri nama Router A,B, dan C.

Perbedaan dari simulasi yang sebelumnya, pada gambar diatas saya menggunakan sebuah “Kabel Serial” untuk menghubungkan router A dengan router B.

Kabel Serial terdapat 2 ujung yang berbeda:

1. DCE

2. DTE

jika pada Port router yang dipasangkan dengan kabel serial yang ujung DCE, maka pada saat konfigurasi router ada yang perlu ditambahkan perintah nya yaitu :

“clock rate 56000”

ok dech untuk lebih jelas nya, kita langsung aja konfigurasi router nya :

1. mengkonfigurasi Router, lakukan dengan perintah2 berikut.

Pada Router A, terdapat 2 port yang perlu diberikan sebuah IP:

RouterA>en
RouterA#conf T
Enter configuration commands, one per line. End with CNTL/Z.
RouterA(config)#int fa0/0
RouterA(config-if)#ip add 202.134.1.1 255.255.255.0
RouterA(config-if)#no sh
RouterA(config-if)#exit
RouterA(config)#int ser0/0
%Invalid interface type and number
RouterA(config)#int ser1/0
RouterA(config-if)#ip add 10.1.1.1 255.0.0.0
RouterA(config-if)#no sh

Pada Router B :

RouterB>en
RouterB#conf T
Enter configuration commands, one per line. End with CNTL/Z.
RouterB(config)#int fa0/0
RouterB(config-if)#ip add 170.1.1.1 255.255.0.0
RouterB(config-if)#ex
RouterB(config)#int fa0/1
RouterB(config-if)#ip add 200.1.1.1 255.255.255.0
RouterB(config-if)#ex
RouterB(config)#int ser1/0
RouterB(config-if)#ip add 10.1.1.2 255.0.0.0
RouterB(config-if)#clock rate 56000
RouterB(config-if)#no sh

Ket : Pada Port Router B ada sedikit perbedaan yaitu terletak pada perintah yang bercetak tebal, dikarenakan port tersebut terpasang kabel Serial yang bertipe DCE.

pada Router C :

RouterC>en
RouterC#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RouterC(config)#int fa0/1
RouterC(config-if)#ip add 200.1.1.2 255.255.255.0
RouterC(config-if)#ex
RouterC(config)#int fa0/0
RouterC(config-if)#ip add 192.168.1.1 255.255.255.0
RouterC(config-if)#no sh
RouterC(config-if)#

2. Menentukan Alamat Jaringan pada Tiap2 IP address yang telah kita sett.

3. melakukan Routing Dinamic, ketikkan perintah-perintah berikut :

Pada Router A :

RouterA>en
RouterA#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RouterA(config)#router rip
RouterA(config-router)#network 202.134.1.0
RouterA(config-router)#network 10.0.0.0
RouterA(config-router)#

Pada Router B :

RouterB>en
RouterB#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RouterB(config)#router rip
RouterB(config-router)#network 10.0.0.0
RouterB(config-router)#network 170.1.0.0
RouterB(config-router)#network 200.1.1.0
RouterB(config-router)#

Pada Router C :

RouterC>en
RouterC#conf t
Enter configuration commands, one per line. End with CNTL/Z.
RouterC(config)#router rip
RouterC(config-router)#network 200.1.1.0
RouterC(config-router)#network 192.168.1.0
RouterC(config-router)#

4. lakukan percobaan dengan mengirimkan sebuah surat atau melakukan perintah ping.

Sekian dulu,,,Mudah2n bermanfaat y

bagi saya pribadi dan bagi teman2n juga………..


			

Update Data MYSQL di VB.net


Sebelumnya kita udah membahas bagaimana Insert dan Delete data di VB.net. pada kali, kita akan mencoba bagaimana Update data dari MYSQL di VB.net. Berikut design Form nya sama dengan form yang sebelumnya :

pada form diatas, saya sengaja tidak menambahkan Button Update.

Logikanya gini ->Button Update nantinya terletak pada Button save, maksdunya adalah ketika kita mengetikkan nobp pada TextBox nobp, apabila nobp yang kita ketikkan ada pada Database maka Button Save akan berubah menjadi Button Update.

pada script kali ini, kita menambahkan sebuah variabel “simpan “yang bertype data BOOLEAN. Yg mana cuman bernilai False dan True. Jika simpan bernilai false, maka button save berubah menjadi update, dan sebaliknya.

Untuk lebih jelas nya, ketikkan lah script code berikut :

1. jangan lupa terlebih dahulu tambahkan sebuah variabel, dibawah “public class Form”

Dim simpan As Boolean

2. double klik pada TextBox nobp, ketikkan script berikut :

If txtnobp.Text.Length = 7 Then
            kon.Open()
            perintah.Connection = kon
            perintah.CommandType = CommandType.Text
            perintah.CommandText = "SELECT * FROM coba WHERE nobp = '" & txtnobp.Text & "'"
            perintah.ExecuteNonQuery()
            cek = perintah.ExecuteReader()
            cek.Read()

            If cek.HasRows Then
                txtnama.Text = cek.Item("nama")
                txtalamat.Text = cek.Item("alamat")
                cmbjenkel.Text = cek.Item("jenkel")
                txttmplahir.Text = cek.Item("tmplahir")
                dtptgllahir.Value = cek.Item("tgllahir")
                'jika data ada simpan bernilai false
                simpan = False
 Button1.Text = "&UPDATE"

            Else
                simpan = True
 Button1.Text = "&SAVE"

                txtnama.Clear()
                txtalamat.Clear()
                cmbjenkel.Text = ""
                txttmplahir.Clear()
            End If
            cek.Close()
            kon.Close()

        End If
    End Sub

3. Langkah selanjutnya Double klik Button Save, kemudian ketikkan Script code berikut :

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

        Try
            kon.Open()
            perintah.Connection = kon
            perintah.CommandType = CommandType.Text
            If simpan = False Then
                perintah.CommandText = "UPDATE coba SET nama = '" & txtnama.Text & _
                "',alamat = '" & txtalamat.Text & "',jenkel = '" & cmbjenkel.Text & _
                "',tmplahir = '" & txttmplahir.Text & "',tgllahir = '" & Format(dtptgllahir.Value, "yyyy-MM-dd") & "' WHERE nobp = '" & txtnobp.Text & "'"
                MsgBox("Data Sukses di Update", MsgBoxStyle.MsgBoxRight, "Message")

            Else
                perintah.CommandText = "INSERT INTO coba VALUES('" & txtnobp.Text & _
            "','" & txtnama.Text & "','" & txtalamat.Text & "','" & cmbjenkel.Text & _
            "','" & txttmplahir.Text & "','" & Format(dtptgllahir.Value, "yyyy-MM-dd") & "')"

                MsgBox("Data Sukses disimpan", MsgBoxStyle.MsgBoxRight, "Message")
            End If

            perintah.ExecuteNonQuery()
            kon.Close()
            Call tampilkan()
            Call kosong()

        Catch ex As Exception
            MsgBox("Data Gagal disimpan,,,periksa koneksi", MsgBoxStyle.MsgBoxRight, "Message")
        End Try

    End Sub

pada script diatas sama dengan script yang sebelumnya, yang berbeda cuman pada logika “if”. Maksud dari logika diatas adalah pada script yang pada TextBox nobp, kita berikan variabel “simpan” bernilai false, yang mana digunakan untuk Update data. Oleh karena itu, kita buat sebuah perintah Update didalamnya.

mudah2an bermanfaat… ^_^

tunggu posting selanjutnya………………